Boost C++ Libraries: Ticket #265: typos in wrapping_int.hpp https://svn.boost.org/trac10/ticket/265 <pre class="wiki">In the following code: template&lt;typename int_type_, int_type_ wrap_min, int_type_ wrap_max&gt; class wrapping_int2 { public: typedef int_type_ int_type; static unsigned long wrap_value() {return wrap_max;} static unsigned long min_value() {return wrap_min;} ... the last two lines should probably read (changing return types and the first function's name): static int_type max_value() {return wrap_max;} static int_type min_value() {return wrap_min;} May I suggest renaming this class to "top_wrapping_int" in reaction to the comment above it? </pre> en-us Boost C++ Libraries /htdocs/site/boost.png https://svn.boost.org/trac10/ticket/265 Trac 1.4.3 az_sw_dude Tue, 25 Oct 2005 12:45:15 GMT <link>https://svn.boost.org/trac10/ticket/265#comment:1 </link> <guid isPermaLink="false">https://svn.boost.org/trac10/ticket/265#comment:1</guid> <description> <pre class="wiki">Logged In: YES user_id=579686 2005-Oct-25 Fix has been checked into CVS-Head (version 1.8). Change will be in release 1.34. I didn't change the name of the class for now. I expect this may be eventually deprecated by other changes. </pre> </description> <category>Ticket</category> </item> <item> <dc:creator>az_sw_dude</dc:creator> <pubDate>Tue, 25 Oct 2005 12:45:16 GMT</pubDate> <title>status changed https://svn.boost.org/trac10/ticket/265#comment:2 https://svn.boost.org/trac10/ticket/265#comment:2 <ul> <li><strong>status</strong> <span class="trac-field-old">assigned</span> → <span class="trac-field-new">closed</span> </li> </ul> Ticket