Opened 10 years ago
Last modified 10 years ago
#7597 new Feature Requests
transform_output_iterator
Reported by: | Owned by: | jeffrey.hellrung | |
---|---|---|---|
Milestone: | To Be Determined | Component: | iterator |
Version: | Boost Development Trunk | Severity: | Not Applicable |
Keywords: | iterator transform transform_output transform_output_iterator | Cc: |
Description
Hello,
This ticket is related to the proposal that I made in the mailing list some weeks ago. The proposal is about adding a new iterator, the transform_output_iterator (initially called chained_output_iterator). Please see the code, unit tests and documentation attached for details. Everything is also available on github: github.com/ldionne/boost-submissions
I was not able to generate the documentation as a whole, so only the rst documents are attached. Please do not hesitate to contact me for any issues/comments.
Thanks,
Louis Dionne
Note: Regarding the mean for composing iterators (using the and_then method), I am open for discussion if another solution would be more desirable. However, this is the result of several attempts to reduce the requirements on the UnaryFunction type and it is the only way I found not to require UnaryFunction to have member typedefs.
Attachments (5)
Change History (8)
by , 10 years ago
Attachment: | transform_output_iterator.hpp added |
---|
comment:1 by , 10 years ago
I am unable to attach the new index.rst because it contains links to external content and is being flagged as potential spam when I try to upload it. Please refer to the index.rst in the github repository.
comment:2 by , 10 years ago
The discussion on the mailing list can be seen there: http://boost.2283326.n4.nabble.com/iterator-property-map-Enhancement-proposals-td4636386.html
by , 10 years ago
Attachment: | transform_output_iterator_test.2.cpp added |
---|
unit test - added a test case so use this one instead
by , 10 years ago
Attachment: | transform_output_iterator.2.hpp added |
---|
use disable_if<> instead of enable_if<not_<>>. Please use this one instead.
comment:3 by , 10 years ago
Owner: | changed from | to
---|
implementation