Opened 18 years ago

Closed 17 years ago

#265 closed Bugs (None)

typos in wrapping_int.hpp

Reported by: morban Owned by: az_sw_dude
Milestone: Component: date_time
Version: None Severity:
Keywords: Cc:

Description

In the following code:

template<typename int_type_, int_type_ wrap_min, 
int_type_ wrap_max>
class wrapping_int2 {
public:
  typedef int_type_ int_type;
  static unsigned long wrap_value() {return wrap_max;}
  static unsigned long min_value()  {return wrap_min;}
...


the last two lines should probably read (changing return 
types and the first function's name):

  static int_type max_value() {return wrap_max;}
  static int_type min_value()  {return wrap_min;}

May I suggest renaming this class to "top_wrapping_int" 
in reaction to the comment above it?

Change History (2)

comment:1 by az_sw_dude, 17 years ago

Logged In: YES 
user_id=579686

2005-Oct-25 Fix has been checked into CVS-Head (version
1.8). Change will be in release 1.34.

I didn't change the name of the class for now.  I expect
this may be eventually deprecated by other changes.

comment:2 by az_sw_dude, 17 years ago

Status: assignedclosed
Note: See TracTickets for help on using tickets.